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About PowerLab 8 
 

Á Simple to operate: just connect PowerLab 8 between a power source and a pack, 

select a pack-specific preset and start charging, discharging, cycling or monitoring. No 

jumpers, plugs or dials to set!  During Auto Charge, PowerLab 8 automatically 

determines pack capacity and sets optimal current, then dynamically adjusts charge 

rate as needed. Alternatively, select manual charge rates from 10mA to 40A. 
 

Á Supports both balanced (depending on chemistry) and non-balanced charging (with 

certain safety limitations) of the following chemistries: 

¶ LiPo (1s to 8s balanced, 1s to 2s unbalanced; maximum charge rate of 2.0A for 

unbalanced charging). 

¶ Li-Ion (1s to 8s balanced, 1s to 2s unbalanced; maximum charge rate of 2.0A for 

unbalanced charging). 

¶ A123©/LiFePO4 (1s to 8s balanced, 1s to 10s unbalanced; maximum charge 

rate of 20A for unbalanced charging). 

¶ LiMn (1s to 8s balanced, 1s to 2s unbalanced; maximum charge rate of 2.0A for 

unbalanced charging). 

¶ NiCd (1s to 21s; maximum charge rate of 20A). 

¶ NiMH (1s to 21s; maximum charge rate of 20A). 

¶ 6V, 12V, 24V Lead Acid (Flooded, Gel, AGM, SLA). 

Á Holds up to 25 user configurable presets (User Presets), optimized for the different 

chemistries, providing charging strategies for most common RC charging needs. Also 

holds up to 50 Library Presets. When using the free Charge Control Software, the 

number of custom presets is virtually unlimited and will grow over time to meet 

industry needs. Replace and customize presets to match your battery inventory. 

Á During balanced charging, each cell is balanced independently, providing exceptional 

charging safety and elevating RC packs to the safety level of cell phones. Typical 

packs of up to 4Ah capacity charge in 40 minutes or less using chargerôs 3C Auto 

Current Mode. 

Á Latest technology provides the ultimate in safetyðeven charges packs having hidden 

physical damage without danger of fire. A pack will not charge if individual cell 

voltages donôt equal total pack voltage. 

Á Cell balancing to 78ɛV accuracy with a tolerance of 6mV and automatic over-charge 

protection assure longest pack life. Automatic temperature monitoring prevents pack 

over-charging at low ambient temperatures and charger damage at high ambient 

temperatures. Cold weather settings adjustable per preset.  

Á Selectable modes: charge only, discharge only, cycle (charge/discharge any number 

of times) and monitor (no charge or discharge, just measure pack voltage). 

Á Selectable discharge:  
 

¶ Internal discharge 10mA to 10A, 100W max. 

¶ Regenerative discharge 10mA to 40A, 1344W maximum when powering the 

PowerLab 8 from a Lead Acid battery. Regenerative discharge takes most of that 

energy and puts it back into the input battery. For example, when you discharge 

a LiPo pack for storage, you will be recharging your Lead Acid input battery. 

Á Multifunction backlit display lets you select presets, replace default presets from a 

library and shows charging data such as individual cell voltages, charge current, 

supply voltage, and amount of charge (mAh) put into pack. Plus, the unique Fuel 

display shows percent capacity remaining in a pack. 
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Á PowerLab 8 Charge Control Software (CCS, a free download) allows you to 

customize, save and load presets (including data displays), and view real-time 

charging data and graphs. CCS also manages firmware updates to keep PowerLab 8 

operating smoothly, and to keep you up-to-date with latest features and 

enhancements. 

Á Parallel charging takes advantage of the PowerLab 8ôs high power output. After 

connecting packs using Safe Parallel Adapters, simply tell PowerLab 8 how many 

packs are attachedðcharge/discharge rates are automatically divided among the 

packs. 

Á Smart Power Management, once configured, prevents damage to your power supply 

or storage battery. 

Á Operates from any 12ï24V DC power source. Inputs and outputs are protected 

against reverse polarity.  

Á Expansion Channel Mode enables multiple PowerLab 8 units to be inter-connected, 

for highly efficient charging of multiple packs of the same chemistry. The primary 

PowerLab 8 communicates with the enhancement units, sends selected preset 

configurations over the network, and controls all aspects of charging and balancing for 

the expansion units.
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Using PowerLab 8 
 
 

 

Quick reference 
 

 
This quick reference lists common PowerLab 8 tasks. What do you want to do? 
 

To do thisé Do thisé  

 

Select power 

source type* 

1. Apply power.   

2. Press any button.  

3. At the Power Source? screen, use the INC or DEC button to select Battery 
or DC Power Supply (i.e., what is currently powering the PowerLab 8). 

 

4. Press ENTER to display User Preset menu.  

 

 

 

 

 

Navigate the 

menus 

Á In the User Presets menu: Press INC and DEC to scroll through User 
Presets. Press and hold INC or DEC to scroll rapidly. 

 

Á In the User Presets menu: Press ENTER to set up to charge with the 
displayed preset. 

 

Á In menus: Press INC and DEC to scroll through options. Press and hold INC 
or DEC to scroll rapidly. 

 

Á In menus: Press ENTER to select the displayed option and move to the next 
screen. 

 

Á Press BACK to go back one screen.  

Á Press and hold BACK to go directly to the User Presets menu from any 
location. 

 

Á Press INC+DEC (i.e., simultaneously) to access Preset Settings, Charger 
Options, Manage Presets and Button Help functions. 

 

 

 

Connect a pack 

Á For balanced charging up to 3A: Attach 9-pin connector to Balance Port (may 
require adapter). 

Details 

Á For balanced charging at any current: Attach pack discharge wires to Output 
jacks using banana cable, attach 9-pin connector to Balance Port (may 
require adapter). 

 

Á For non-balanced charging: Attach pack discharge wires to Output jacks 
using banana cable. 

 

IMPORTANT: To prevent damage to the power source, you must specify the 

power sourceôs voltage and current cutoffs before charging for the first time 

with a DC power supply, and before charging for the first time from a battery. 

After that, update the power sourceôs operating characteristics any time you 

change to a different DC power supply or battery. You can also specify cutoffs 

in the CCS Supply tab. 
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Charge, 

discharge, cycle 

or monitor a 

pack 

1. Apply power and select power source (see above). Details 

2. Connect pack.  

3. Press INC or DEC to select desired User Preset, then press ENTER.  

4. For each question, press INC or DEC to select correct answer, then press 
ENTER. 

 

5. CHECKING PACK indicates PowerLab 8 is attempting to detect attached 
pack. 

 

6. Screen displays presetôs chemistry. If this matches packôs chemistry, press 
ENTER to start. (If they donôt match, just wait for the next prompt, then press 
ENTER to return to the User Preset menu.) 

 

7. During the operation: 

¶ Press INC or DEC to view data. 

¶ Press ENTER to change charge current. 

¶ Press and hold ENTER to stop the operation. 

 

8. ñBeep beep beepò indicates the operation is complete. Display shows 
elapsed time. Press INC/DEC to review data.  Operation is complete, but 
ñsessionò remains open so you can review collected data.  Press and hold 
ENTER to terminate session (this erases session data). 

 

9. Disconnect pack.  

10. Press ENTER to return to User Preset menu.  

Charge packs in 

parallel 

To ensure safety, only use REVOLECTRIX Safe Parallel Adapters and stackable 
safety banana plugs when charging/discharging/cycling packs in parallel. 
Connect up to 9 batteries of same chemistry, cell count and capacity in parallel 
by stacking banana plugs. Charge as above, but enter number of packs at 
Parallel Packs? question (e.g., 2P, 3P, 4P). PowerLab 8 multiplies presetôs 
current setting by the number of ñPò selected. 

Details 

 

*Assumes Choose Power Source at Startup is enabled in the CCS. 
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Set Smart Power Management 
 

 
 

You can set a variety of operating options, including the very important power source 
voltage and current limits. You can set Smart Power Management either at the 
PowerLab 8 (described below) or in the CCS Supply tab (which is easier). 

Because the PowerLab 8 is capable of high power output, it is strongly recommended 
that you configure Smart Power Management before you use the PowerLab 8 for 
the first time, and set it again any time you significantly change the power source - 
either DC power supply or Lead Acid battery. 

The PowerLab 8 stores two Smart Power Management profiles: one for a DC power 
supply and one for a Lead Acid battery. When you apply power to the PowerLab 8, the 
first thing you do is select the profile that matches the power source you are using. This 
makes it easy to change the Smart Power Management profile from a DC power supply 
at home to a Lead Acid battery at the field. 

If you donôt configure Smart Power Management to match your power source(s), these 
are the default settings: 

Á DC supply power source:  

¶ Voltage lower limit: 10V  

¶ Current upper limit: 25A 
 

Á Battery power source:  

¶ Voltage lower limit: 11V  

¶ Current upper limit: 25A 
 

Á Regenerative discharge, when enabled (it is disabled by default):  

¶ Regenerative voltage upper limit into Lead Acid battery: 14.40V 

¶ Regenerative current upper limit into Lead Acid battery: 10A 
 

 
The following procedure sets Smart Power Management for both a DC power supply and 
a Lead Acid battery. 

1. Connect PowerLab 8 to a 10ï32V DC power supply or Lead Acid battery.  

2. Press any button on PowerLab 8ôs panel.  

3. At the Power Source? screen, use the INC or DEC button to select Battery or DC 
Power Supply (i.e., what is currently powering the PowerLab 8). 

4. Press ENTER to display the User Preset menu. 

5. Press INC+DEC (i.e., press both INC and DEC at the same time) to display the 
Options menu (Choose TASK?). 

6. Press INC or DEC until you see Charger Options, then press ENTER.  

7. The Charger Address? screen should display PRIMARY CHANNEL (unless you are 

IMPORTANT: To prevent damage to the power source, you must specify the 

power sourceôs voltage and current cutoffs before charging for the first time 

with a DC power supply, and before charging for the first time from a battery. 

After that, update the power sourceôs operating characteristics any time you 

change to a different DC power supply or battery. 

Note: All of the above parameters can be adjusted directly on the PowerLab 

8, except Regenerative Amps and Regenerative Voltage, which must be set 

using CCS. 
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running multiple PowerLabs in Expansion Channel mode). If it doesnôt, press INC or 
DEC until you see PRIMARY CHANNEL. Press ENTER.  

8. At the Power Source? screen, press INC or DEC to select DC Power Supply, then 
press ENTER. 

9. At the Supply Current Limit? screen, press INC or DEC to specify the current limit 
appropriate for your DC power supply, then press ENTER. (Cutoff current should be 
slightly less than the power sourceôs maximum output current capability. To protect 
your power supply from damage, PowerLab 8 will never draw more current than you 
specify here, but charge current may not reach the preset or manually set value.) 

10. At the Low Sply Limit? screen, press INC or DEC to specify the cutoff voltage, 
then press ENTER. (Cutoff voltage should be about 50% lower than the power 
supplyôs nominal output voltage. Example: For a 24V power supply, set the cutoff 
voltage to 12V. To protect your power supply, charging stops if the power 
supplyôs voltage drops below the value you set here.) 

11. At the Use Regenerative Discharge? screen, press and hold the BACK button, as 
this feature does not apply to DC Power Supply setup. You will be returned to the 
User Preset menu. You have now successfully set Smart Power Management for 
your DC power supply. Next, repeat the process for your Lead Acid battery. 

12. Press INC+DEC (i.e., press both INC and DEC at the same time) to display the 
Options menu (Choose TASK?). 

13. Press INC or DEC until you see Charger Options, then press ENTER. 

14. At the Power Source? screen, press INC or DEC to select Battery, then press 
ENTER. 

15. At the Battery Current Limit? screen, press INC or DEC to specify the current 
limit appropriate for your Lead Acid battery, then press ENTER. (Maximum 
output current capability of Lead Acid batteries varies widely. Generally, a 
standard flooded Lead Acid car battery might deliver 25A continuously and 50A 
for short periods. An AGM style might not have any trouble delivering 50A 
continuously without suffering substantially shortened life. To protect your battery 
from damage, PowerLab 8 will never draw more current than you specify here, 
but charge current may not reach the preset or manually set value.) 

16. At the Bat. Low Cutoff? screen, press INC or DEC to specify the cutoff voltage, then 
press ENTER. (Cutoff voltage should be no lower than 11V for a 12V Lead Acid 
battery. Lower cutoff will provide longer PowerLab 8 operating time at the expense of 
Lead Acid battery life. If you are using two 12V batteries in series for 24V operation, 
PowerLab 8 will automatically double the cutoff voltage you set here. To protect your 
power supply, charging stops if the power supplyôs voltage drops below the value you 
set here.) 

17. At the Use Regenerative Discharge? screen, press INC or DEC to enable or 
disable this feature, then press ENTER. (Regenerative discharge puts energy back 
into a battery power source during pack discharge cycles.) 

18. Press and hold the BACK button to return to the User Preset menu. 

 

Smart Power Management setup is now complete. The next time you cycle power to the 
PowerLab 8, it will prompt you to select either DC Power Supply or Battery as the power 
source, but it will use the settings you entered to manage power from the selected 
source. 

 
See also 
CCS Supply tab
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Set options 

 
1. Connect PowerLab 8 to a 10ï32V DC power supply or Lead Acid battery.  

2. Press any button on PowerLab 8ôs panel.  

3. At the Power Source? screen, use the INC or DEC button to select Battery or DC 
Power Supply (i.e., what is currently powering the PowerLab 8). 

4. Press ENTER to display the User Preset menu.  

5. Press INC+DEC (i.e., press both INC and DEC at the same time) to display the 
Options menu (Choose TASK?). 

6. Press INC or DEC until you see Charger Options, then press ENTER.  

7. The Charger Address? screen should display PRIMARY CHANNEL (unless you are 
running multiple PowerLabs in Expansion Channel mode). If it doesnôt, press INC 
until you see PRIMARY CHANNEL. Press ENTER. 

8. The next screen is the Power Source? Screen.  (See Set Smart Power Management 
for instructions on setting the Power Source and Regenerative Discharge options.) 

9. Press ENTER until you see the Node Connector? Screen.  For more information 
about wiring modes, see FMA Wiring mode vs. XH/EH Wiring mode. 

10. Press ENTER until you see the Decimal Places for Cells? screen. At the Decimal 
Places for Cells? screen, press INC or DEC to select 2 or 3, then press ENTER. 
(This controls how many decimal places are displayed in cell voltage data screens.) 

11. At the Quiet Charging? screen, press INC or DEC to select Y or N, then press 
ENTER. (Y = no beeps during charging, N = beeps during charging.) 

12. At the Speaker Volume? screen, press INC or DEC to set speaker volume, then 
press ENTER. (1 = quietest. While setting volume, speaker beeps at volume shown 
on screen.) 

13. At the Charge Complete Beeps? screen, press INC or DEC to set the number, then 
press ENTER. (This controls how many times PowerLab 8 repeats ñbeep beep beepò 
when charging is complete.) 

14. At the Preset Changes Always Save? screen, press INC or DEC to select Y or 
N, then press ENTER. (Y = changes made to a User Preset at PowerLab 8 are 
always saved to the loaded preset and uploaded to the Charge Control Software. 
Setting to N is not recommended, but it provides a way to temporarily override 
preset parametersðonce you move to another preset, any changes you made 
will be lost and the preset will revert to its previous state.)  No matter what you 
choose for this option, you can always over-ride charge and discharge rate on-
the-fly at the PowerLab 8 after a charge is started by pressing ENTER.  This 
method never saves the changes to the preset in use. 

15. At the Choose TASK? screen: 

Á Press INC or DEC to select another setup function.  

Á Press BACK to display the User Preset menu. 

 
See also 
CCS Options tab

Tip: A setting is saved as soon as you change it. Also, you donôt have to go 

through the entire sequence belowðat any time, you can press and hold the 

BACK button to return to the User Preset menu. 
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Connect packs: basic 
 

Connect the pack to PowerLab 8ôs Output jacks, Balance Port or both. 

 
 
 
 
 
 
 
 
 
 
 

The Balance Port accepts a 9-pin Cellpro balance connector, which supports packs up to 
8s. For charge/discharge rates up to 3A, you can attach just the balance connector, as 
shown below. If the pack has a different style balance connector, REVOLECTRIX offers 
a variety of adapters for most popular connector types and brands (visit the  Cellpro 
Adapters section in the REVOLECTRIX Web site). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

If the pack has both heavy discharge wires and a balance connector, you can connect 
both to PowerLab 8 (good for any charge/discharge current): 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: Best practice is to connect balance connector first, then connect 

discharge wires.  When the PowerLab 8 is set to XH/EH wiring mode, you 

must connect both the balance connector and the discharge wires. 

http://www.revolectrix.com/cellpro_adapters.htm
http://www.revolectrix.com/cellpro_adapters.htm
http://www.revolectrix.com/cellpro_adapters.htm
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For non-balanced charging, connect the pack to PowerLab 8 like this: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

If stock REVOLECTRIX adapters donôt work for your packs, you can make your own 
adapters using the CPBP9P-10 Cellpro battery pigtail 10", 9 position, which consists of a 
9-pin connector with un-terminated wires. See Balance connector wiring and the ñCellPro 
Battery Wiring Diagramò available from the REVOLECTRIX Web site. 

 

 
 
 
 
 
 
 
 
 
See also 
Balance connector wiring 
XH/EH wiring mode

Note:  After a charge is initiated, never alter the connections between the 

charger and the battery packs.  Always end the current charge session before 

making any connection changes.  See page 33 for more information about 

STARTING and STOPPING charge sessions. 

http://www.revolectrix.com/support_docs/item_1315.pdf
http://www.revolectrix.com/support_docs/item_1315.pdf
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Connect packs: advanced 
 

The table below lists several common PowerLab 8 charging configurations. Find the con-
figuration that most closely matches how you want to charge, then click the ñDetailsò link 
for more information. 

 
    Connect   

 Number of Number   Discharge Number of  

Ref packs of PL8s Mode Balance wires wires power sources  

A 1 1 Normal Yes No 1 Details 
B 1 1 Normal Yes Yes 1 Details 
C 2 and up* 1 Normal Yes Yes 1 Details 
D 1 (10s and up 1 Normal Yes Yes 1 Details 

 with center tap)       

E 2 2 Normal Yes Yes 1 Details 
F 2 2 Normal or Yes Yes 1 Details 

   Expansion Chan-     

   nel     

G 1 (10s and up 2 Normal or Yes Yes 1 Details 
 with center tap)  Expansion Chan-     

   nel     

H 1 (10s and up 2 Normal Yes Yes 2, isolated Details 
 with center tap)       

  *Above 9 packs in parallel, you are responsible for determining the charge/discharge current for each pack.  
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Configuration A 
 

Summary:  basic one-pack charging through balance wires. 

Components: 

Á 1 PowerLab 8  

Á 1 power source  

Á 1 standard adapter (Safe Parallel Adapter does not support balance-wire-only 

charging)  

Á 1 pack  

Á Optional FUIM3 for computer support  

 

PowerLab 8 mode (Normal or Expansion Channel): Normal. 

 

PowerLab 8 maximum charge power: up to 100W charge to 1 pack (8s); balance-wire-
only charging limited to 3A max. 
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Configuration B 
 

Summary:  basic one-pack charging through balance and discharge wires. 

Components: 

Á 1 PowerLab 8  

Á 1 power source  

Á 1 standard adapter or Safe Adapter  

Á 1 pack  

Á Optional FUIM3 for computer support  

 

PowerLab 8 mode (Normal or Expansion Channel): Normal. 

 

PowerLab 8 maximum charge power: up to 1344W charge to one pack (8s) using 
24VDC/1700W power source. 
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Configuration C 
 

Summary:  parallel charging. 

Components: 

Á 1 PowerLab 8  

Á 1 power source  

Á 1 Safe Parallel Adapter for each pack (do not use standard adapters)  

Á 2 or more packs (above 9 packs in parallel, you are responsible for determining 

the charge/discharge current for each pack)  

Á Optional FUIM3 for computer support  

 

PowerLab 8 mode (Normal or Expansion Channel): Normal. 

 

PowerLab 8 maximum charge power: up to 672W charge to each of two packs 
charged in parallel using 24VDC/1700W power source. 

 

Constraints: 

Á 1 pack per adapter.  

Á Check pack polarity.  

Á Same cell count for all packs.  

Á Use discharge leads. 

 

(Illustration next page)
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See also 
Charge packs in parallel 
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Configuration D 
 

Summary:  parallel charging split pack (10s or larger). 

Components: 

Á 1 PowerLab 8  

Á 1 power source  

Á 2 Safe Parallel Adapters  

Á 1 10s (or larger) split pack with center tap  

Á Optional FUIM3 for computer support  

 

PowerLab 8 mode (Normal or Expansion Channel): Normal. 

 

PowerLab 8 maximum charge power: up to 672W charge to each of two packs 
charged in parallel using 24VDC/1700W power source. 

 

Constraints: 

Á 1 pack side per adapter.  

Á Check pack polarity.  

Á Same cell count for both sides.  

Á Use discharge leads. 

 

(Illustration next page) 
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Configuration E 
 

Summary:  two PowerLabs charging separate packs, one power source. 

Components: 

Á 2 PowerLabs  

Á 1 power source  

Á 2 standard adapters or Safe Parallel Adapters (1 adapter per pack)  

Á 2 packs (Safe Parallel Adapters require same cell count for both packs)  

Á 2 optional FUIM3s for computer support with 2 CCS instances  

 

PowerLab 8 mode (Normal or Expansion Channel): Normal. 

 

PowerLab 8 maximum charge power: up to 1344W to each pack (8s) using 
24VDC/3400W power source. Standard house circuit would likely not provide 
enough power; would require 240VAC power supply for full power. 
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Configuration F 
 

Summary: two PowerLabs charging separate packs, one power source, Expansion 
Channel Mode. 

Components: 

Á 2 PowerLabs  

Á 1 power source  

Á 2 standard adapters or Safe Parallel Adapters (1 adapter per pack)  

Á 2 packs (Safe Parallel Adapters require same cell count for both packs)  

Á 1 optional FUIM3 for computer support  

Á 1 optional ñYò servo cable (required for Expansion Channel operation with 

computer support)  

Á Male-male servo cable (required for Expansion Channel operation; required for 

computer support)  

PowerLab 8 mode:  Expansion Channel. 

PowerLab 8 maximum charge power: up to 1344W to each pack (8s) using 
24VDC/3400W power source. Standard house circuit would likely not provide enough 
power; would require 240VAC power supply for full power. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
See also  
Expansion Channel Mode 
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Configuration G 
 

Summary:  two PowerLabs charging split pack (10s or larger), one power source, 
Expansion Channel Mode. 

 

Components: 

Á 2 PowerLabs  

Á 1 power source  

Á 2 standard adapters or Safe Parallel Adapters (1 adapter per side)  

Á 1 10s (or larger) split pack with center tap  

Á 1 optional FUIM3 for computer support  

Á 1 optional ñYò servo cable (required for Expansion Channel operation with 

computer support)  

Á Male-male servo cable (required for Expansion Channel operation)  

 

PowerLab 8 mode:  Expansion Channel. 

 

PowerLab 8 maximum charge power: up to 1344W to each pack (8s) using 
24VDC/3400W power source. Standard house circuit would likely not provide enough 
power; would require 240VAC power supply for full power. 

If not running in Expansion Channel mode, remove the male-mail servo cable and ñYò 
servo cable, and use 2 FUIM3s and 2 CCS instances to control the PowerLabs. 

 

(Illustration next page)
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See also  
Expansion Channel Mode 
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Configuration H 
 

Summary: two PowerLabs charging pack (10s or larger) with center tap, two power 
sources, Normal mode 

Components: 

Á 2 PowerLabs  

Á 2 ELECTRICALLY ISOLATED power sources: Lead Acid batteries or DC supplies 

(see note below)  

Á 2 standard adapters or Safe Parallel Adapters (1 adapter per side)  

Á 1 10s (or larger) pack with center tap  

Á User-provided jumper (see diagram)  

Á 2 optional FUIM3s for computer support with 2 CCS instances  

 

PowerLab 8 mode (Normal or Expansion Channel): Normal only. 

 

PowerLab 8 maximum charge power: up to 1344W to each pack (8s) using two 
24VDC/1700W power source. Standard house circuit would likely not provide enough 
power to both power supplies, so each power supply should be on a separate circuit. 

 

 
 

(Illustration next page)

IMPORTANT: DC power supplies often have a common ground through their 

AC connections, and therefore are not isolated. With the power supplies 

plugged into outlets and turned OFF, use a continuity tester or ohmmeter to 

verify there is no continuity between DC ground outputs of the power supplies 

before connecting the PowerLabs. Failure to ensure the power supplies are 

electrically isolated will damage the PowerLabs as well as the pack. 
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Power supplies 
 

PowerLab 8 is one of the highest power RC battery maintenance devices available. 
Running full power, it can deliver 1344W to batteries during charge. To achieve this, 
even on an 8 cell Li battery, it must boost the input voltage. This means the PowerLab 8 
may draw up to 1600W from the input power supply. 

To take advantage of PowerLab 8ôs full power capability, the power source should be 
26.35V DC (higher voltage does not improve output power), and capable of delivering a 
minimum of 60A to PowerLab 8ôs input. Per Ohmôs law, 26.35V x 60A = 1581W. 
However, it is generally not advisable to pull 100% of available power from a DC power 
supply. Therefore, if you want to attain 1344W of output power to an 8s Li battery, the 
power supply should be capable of 1700W or higher for best results. 

Likewise, if you donôt need PowerLab 8ôs full output power, it can operate from much 
lower power sources. Use the steps outlined in Set Smart Power Management to con-
figure PowerLab 8 to never exceed the maximum capabilities of your input source(s), 
whether DC power supply or Lead Acid battery. 

For more information about power supply selection, please download the PowerLab 8 
Power Calculator spreadsheet found at the PL8 Resources tab on the REVOLECTRIX 
website. 

 

 

See also 
CCS Supply tab 
 
 

Note: Unstable power supplies can damage the charger.  To help reduce risk 

to the charger observe the following: 

 

 ·         When powering more than one Charger/Battery Workstation from the 

same supply, ensure that all connected chargers are idle (not charging) 

when connecting the second or third charger.  Alternatively, connect all 

chargers to the supply before the supply is powered up.   

 

·         When powering the Charger/Battery Workstation from an automotive 

battery (Pb)  installed in a vehicle, do not start or stop the vehicleôs 

engine unless the charger is idle, or disconnected from the automotive 

battery (Pb). 

 

·         During charging, if the charger reports ñSupply Unstableò  determine 

and address the cause. The cause may be related to the supply, the 

wiring, or the stability of the AC source when a generator is used. 

 

·         When powering any Revolectrix Cellpro Charger or Battery Workstation 

using the E-Fuel 1200W/50A power supply:  1) first connect the Power 

Supply to AC power BEFORE connecting the charger to the Power 

Supply; 2) set the voltage on the Power Supply so it is within the 

operating range of the Cellpro Charger or Battery Workstation you will 

be powering; 3) wait at least 15 seconds; 4) then connect the Cellpro 

Charger or Battery Workstation to the Power Supply; 5) conversely, 

disconnect the Cellpro Charger or Battery Workstation from the Power 

Supply BEFORE disconnecting the Power Supply from AC power 

http://www.revolectrix.com/pl8_links_tab.htm
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Charge/discharge/cycle/monitor a pack 
 

 

 
1. Connect PowerLab 8 to a 10ï32V DC power supply or 12ï24V battery.  

2. Press any button to display the Power Source? screen. Then: 

a. Press INC or DEC to specify the power source you are using. 

b. Press ENTER. 

 

 
3. Connect the pack to PowerLab 8:  

 
a. If the pack has a balance connector, connect the balance connector to PowerLab 

8. (See Connect packs: basic for details.) 

b. If you are charging through the packôs discharge wires (required if charge current 
is >3A or if the pack/battery does not have balance wires), connect the banana 
jack cable between the pack/battery and the PowerLab 8.  

 
4. In the User Preset menu:  

 
a. Press INC or DEC to locate the User Preset you want to use. Press and hold INC 

or DEC to scroll rapidly.  

b. Press ENTER, then go to step 5.  

Or 

c. Press and hold ENTER, then go to step 6 (if Enable Quick Start is activated in 
the CCS Options tab; you can skip most questions). 

 
5. For the selected User Preset: 

 
a. Press INC or DEC to select the correct answer to each question, then press 

ENTER. 

¶ Parallel Packs? (select No if charging a single pack, 2P to 9P for parallel 

connected packs; NOT ALLOWED for certain chemistries). 

¶ Set Charge Rate? (select 1.0C, 2.0C, 3.0C or select a current manually). 

¶ Set Dsch. Rate? (select a current). 

Tip: These detailed instructions will help you learn how to navigate through 

the charging process. For brief instructions, see the Quick reference.  Once 

you become familiar with PowerLab 8 operations, you shouldnôt need 

instructions at all. 

IMPORTANT: To prevent damage to the power source, you must specify the 

power sourceôs operating characteristics before charging for the first time with 

a DC power supply, and before charging for the first time from a battery. After 

that, update the power sourceôs operating characteristics any time you change 

to a different DC power supply or battery. 

Note: If this is the first time you are using this power source, you must specify 

the power sourceôs operating characteristics at this time.  If you previously 

specified power source operating characteristics, PowerLab8 will use those 

settings. 

Note: Skip this step if you disabled the Choose Power Source at Startup 

option in the CCS Options tab. 

Note: If you will be charging LiPo pack(s) at 10A or higher, select a preset 

with High Power in its title. 
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b. At the START? question, select one of the following, then press ENTER:  
 

¶ CHARGE ONLY (i.e., no discharge). 

¶ DISCHARGE ONLY (i.e., no charge). 

¶ MONITOR (no charge or discharge, just monitor cell voltages). 

¶ n CYCLE (perform n charge/discharge cycles, as specified in preset). 
 

 
6. At the Use Banana Jacks? question, press INC or DEC to indicate whether the 

banana jack cable is connected between the pack/battery and PowerLab 8, then 

press ENTER. 

 
7. PowerLab 8 displays CHECKING PACK to see whether a pack is connected. If a 

pack is connected, then... 

8. PowerLab 8 displays the presetôs chemistry (for example, LiPo) and prompts you to 
verify it is the same as the packôs chemistry (which should also be, for example, 
LiPo). This safety check is your chance to prevent charging if the preset and pack 
donôt match. 

Á If the displayed chemistry matches the packôs chemistry, press ENTER to start 

charging. Go to step 9. 

Or 

Á If the displayed chemistry does not match the packôs chemistry, do nothingðthe 

screen will time out. At the prompt, press ENTER to see the Preset Menu. Go to 

step 4. 

9. During operations: 

Á Press INC or DEC to view various charging data screens (the number of screens 

and the data displayed depends on how the User Preset is configured). 

 

 
Press ENTER to override the charge and discharge current (for this session only). 

To stop the operation:  

Á Press and hold ENTER. Youôll see CHARGER STOPPED. 

Á Press ENTER to return to the User Preset menu. 

10. When the operation is complete, PowerLab 8 will ñbeep beep beepò several times 
and the display will show ELAPSED [time] / [chemistry] DONE. Press INC and 

DEC to review data screens. 

 

Tip: The number of cycles is specified in the preset. See Edit a User Preset to 

change the number of cycles or any other aspect of the preset. 

Note: Skip this step if you enabled the Suppress Use Bananas Question in 

the CCS Options tab. 

Tip: You can also monitor charging data, and view data in graphs, in the 

Charge Control Software. 

Note: NiMH, NiCd and Lead Acid user presets may switch to trickle charge 

(depending on how the preset is configured) when charging is complete. 
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11. Press and hold ENTER. Screen displays CHARGER STOPPED. 

12. Press ENTER or BACK to return to the User Preset menu. 

13. Disconnect the pack from PowerLab 8. 

14. PowerLab 8 is ready to charge another battery (step 3). 

 

Start faster 
 

When following the instructions above, you probably noticed that PowerLab 8 asks a lot 
of questions before it starts a charge, discharge, cycle or monitor. That enables you to 
specify exactly what operations PowerLab 8 will perform. If all you want to do is Charge 
a battery, and once you have a preset configured properly, two settings in the CCS 
Options tab will speed up the process: 

Activate the Enable Quick Start option.  

When activated, Enable Quick Start lets you bypass many of the questions needed to 
start a process. After activating this feature, press and hold ENTER if you donôt want to 
select options such as discharge/cycle/monitor.  

Disable the Choose Power Source at Startup option (only if you consistently use the 
same power source).  

On startup, PowerLab 8 will always use either the DC Power Supply or Battery profileð
whichever was last loaded before disabling the prompt. 

 

Note: The operation is now complete, but the ñsessionò remains open so you 

can review collected data. Once you press and hold ENTER, data collected 

during the operation will be discarded.  If you disconnect the pack before 

ending the session, PowerLab8 will display a ñPack Removedò error. This is a 

non-critical error, and you can ignore it in this situation. 

Note: You can also enable the Suppress Use Bananas Question option, but 

this is not recommended. 
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Charge/discharge/cycle packs in parallel 
 

PowerLab 8 can charge, discharge or cycle up to nine LiPo or A123 packs in parallel. 
Parallel operations can save a lot of time, but you must follow these rules: 

Á Always use Safe Parallel Adapters (available at the REVOLECTRIX Web site). Never 

use standard adapters. 

Á Connect only one pack per Safe Parallel Adapter. Daisy-chain multiple adapters!  

Á Parallel operations using Safe Parallel Adapters requires that you connect both the 

balance wires and discharge wires to the PowerLab 8.  

Á Always observe proper polarity!  

Á Packs must have the same cell count.  

Á Packs must be the same chemistry.  

The best way to connect discharge wires in parallel is to stack the plugs on the safety 
banana cables like this: 

 

 

 

 

 

 

 

Charging proceeds like single-pack charging, except at the Parallel Packs? question, 
use INC and DEC to specify the number of packs connected in parallel. PowerLab 8 
multiplies the presetôs charge/discharge rates by the number of ñPò selected. 

 

See also 
Connect packs: Configuration C 
 

http://revolectrix.com/cellpro_adapters.htm
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Expansion Channel Mode 
 

In Normal Mode, multiple PowerLabs operate independently. Connect any number of 
PowerLabs to individual computer USB ports, and run multiple instances of CCS. Each 
PowerLab 8 communicates with a separate instance of CCS. 

In Expansion Channel Mode, multiple PowerLabs are connected via each unitôs PC port. 
Use this mode when you want to charge multiple, similar packs with reduced button 
presses. Expansion Channel Mode is a modular approach to maintaining similar 
batteries: the batteries must be the same chemistry, but the cell counts can be different. 

As delivered, all PowerLabs are configured to run as a ñPrimaryò or ñMasterò unit. In the 
OPTIONS menu, you designate one or more PowerLabs as an ñExpansionò unit, e.g., 
Expansion Ch. 1, Expansion Ch. 2, etc. Communicating through the PC ports, the 
Primary unit controls the operations of all Expansion unitsðpower source setups, 
options and presets. All Expansion unit keypads are disabled except for one function 
than enables them to be made Primary units again: INC+DEC to display the OPTIONS 
menu. 

 
To operate in Expansion Channel Mode: 

Á Packs must have the same chemistry, since one preset controls charging, discharging 

or cycling on all PowerLabs. 

Á Packs can have different cell counts provided that the selected preset is set to auto-

detect the cell count. 

Á Packs can be at different levels of charge at start. 

 
1. (Optional) Interlock the PowerLab 8 cases using the guides on the enclosure sides. 

For a permanent installation, use two small screws to secure the cases.  Servo 
mounting screws work well for this purpose. 

2. Connect two PowerLabs using a male-male servo cable. When connecting more than 
two PowerLabs, or when you are connecting to a computer for CCS support, use ñYò 
servo cables as needed (see Configuration F and Configuration G, for example). 

3. Designate one PowerLab 8 as the primary unit, and assign each of the others a 
unique Expansion Channel address. On each PowerLab 8:   
a. Press INC+DEC to display the Options menu (Choose TASK?). 

b. Press INC or DEC until you see Charger Options, then press ENTER. 

c. In the Charger Address? screen, select PRIMARY CHANNEL for the primary 
unit, or select EXPANSION CH. n for the other units (each unit must have a 
unique channel address), then press ENTER. 

d. As needed, set other options. 

e. Press and hold BACK to exit options.  
 

4. Connect a pack to each unit. 

5. On the Primary unit: 

a. Select the User Preset appropriate for all packs, then press ENTER. 

b. Answer all the questions and initiate charging.  

c. PowerLab 8 displays CHECKING PACK to see whether a pack is connected at 
each unit. If packs are connected, then... 

d. Verify that the preset chemistry matches the packsô chemistries by pressing 

Note: In Expansion Channel Mode, every PowerLab 8 must have a battery 

connected, otherwise the Primary unit will invoke a Safety Code. 
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ENTER. 

6. During charging: 

Á Press INC or DEC on the Primary unit to view charging data. Data will be 

displayed on each PowerLab 8 for the pack connected to that unit. 

 
Á Press ENTER on the Primary unit to override the charge and discharge current 

(for all units). 

To stop charging on all units:  

Á On the Primary unit, press and hold ENTER. Youôll see CHARGER STOPPED.  

Á Press ENTER to return to the User Preset menu.  
 

7. When charging is complete, each unit will ñbeep beep beepò several times and the 
display will show ELAPSED [time] / [chemistry] DONE. On the Primary unit, press 
INC and DEC to review charging data screens. Data will be displayed on each 
PowerLab 8 for the pack connected to that unit. 

 

 

8. After all units have completed charging, on the Primary unit press and hold ENTER. 
Screen displays CHARGER STOPPED. 

9. On the Primary unit, press ENTER or BACK to return to the User Preset menu. 

10. Disconnect the packs from all units. 

 

Tip: You can also monitor charging data, and view data in graphs, in the 

Charge Control Software.  In the Cells, Int. Res. and Supply tabs, use the 

drop-down lists to display data from a specific Expansion Channel unit. 

Note: The operation is now complete, but the ñsessionò remains open so you 

can review collected data.  Once you press and hold ENTER, data collected 

during the operation will be discarded.  If you disconnect the pack before 

ending the session, PowerLab 8 will display a ñPackRemovedò error. This is a 

non-critical error, and you can ignore it in this situation. 

Note: NiMH, NiCd and Lead Acid user presets may switch to trickle charge 

(depending on how the preset is configured) when charging is complete. 
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Regenerative discharge 
 

Regenerative discharge routes most of the energy from the pack being discharged back 
into the Lead Acid battery powering the PowerLab 8. This feature is only available when 
the PowerLab 8 is powered from a Lead Acid battery. Regenerative discharge supports 
up to 40A, 1344W maximum. 

Regenerative discharge 

Á Enable/disable regenerative discharge at the PowerLab 8 via Smart Power 

Management  for the supply battery.  

Á Enable/disable regenerative discharge, and set maximum discharge current and 

maximum discharge voltage, in the CCS Supply tab. Remember also to set supply 

battery low voltage cutoff and maximum output current for charge cycles.  

PowerLab 8 automatically determines whether it is connected to a Lead Acid battery or a 
DC power supply. If it detects a power supply, it switches to internal discharge (10mA to 
10A, 100W maximum).
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Modify a preset 
 

You can change many preset properties directly on PowerLab 8. Use this procedure at 
any time, but itôs essential when PowerLab 8 isnôt connected to the Charge Control Soft-
ware. 

 
1. In the User Preset menu, use INC or DEC to select the preset you want to modify. 

Press and hold INC or DEC to scroll rapidly. 

2. Press INC+DEC to access options. 

3. At the Choose TASK? > Preset Settings screen, press ENTER. You now see the 
first of several settings for the preset. 

4. In each property screen: 

Á Press INC or DEC to select the desired value, then press ENTER to save that 

value and move to the next screen.  

Á Press ENTER to move to the next setting screen without changing the property.  

Á Press BACK to move to the previous setting screen.  

Á At any time, press and hold BACK to return to the User Preset menu. Property 

changes you made will be applied to the preset. 

5. When you see Choose TASK? > Preset Settings again, you have completed a full 
pass through all properties for the preset. 

6. Press BACK to return to the User Preset menu. 

 

 
 
 
 
 
See also 
CCS Presets tab 
Manage presets 

Tip: You can also use the Charge Control Softwareôs Presets tab to hide, 

show, re-arrange, copy and modify presets. 
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Manage presets 
 

On PowerLab 8 you can: 

Á Clear a User Preset.  

Á Copy a Library Preset for use as a User Preset. 

 

 

Clear a User Preset 
 

You can remove User Presets you donôt need. For example, if you donôt regularly charge 
A123 and Lead Acid batteries, you can remove those to limit the Preset Menu to the 
presets you do use. 

 
1. In the User Preset menu, use INC or DEC to select the preset you want to clear. 

Press and hold INC or DEC to scroll rapidly. 

2. Press INC+DEC to access options. 

3. In the Choose TASK? screen, press INC until you see Manage Presets, then press 
ENTER. 

4. In the Clear Current Preset? screen, press INC to display Y, then press 
ENTER. 

5. In the Confirm CLEAR Preset? screen, press INC to display Y, then press ENTER. 

6. In the Preset Cleared screen, press and hold BACK to return to the User Preset 
menu. Youôll see EMPTY PRESET for the preset you just cleared. 

 

Copy a Library Preset 
 

PowerLab 8 is equipped with up to 50 Library Presets. A Library Preset (which you canôt 
change) is a starting point for creating your own User Preset (which you can change). 
FMA configures Library Presets with optimal charge characteristics for a variety of 
battery chemistries and charging strategies. You can replace an existing User Preset 
with a Library Preset, orðif less than 25 User Presets are installedðyou can create a 
new User Preset from a Library Preset. After you load a Library Preset into a User 
Preset slot, you can change its properties. 

Tip: You can also use the Charge Control Softwareôs Presets tab to hide, 

show, re-arrange, copy and modify presets. 

Note: If the Preset Changes Always Save? option is set to Y in PowerLab 8  

options, or if the Save Preset Changes done at PowerLab option is enabled 

in the CCS Options tab, and if CCS is running and communicating with 

PowerLab 8, cleared and copied presets are reflected in the CCS Presets tab. 

Tip: The CCS has better tools for managing presets (see Presets tab). 

Deleting a preset at the PowerLab 8, for example, leaves an empty preset 

location. In contrast, the CCS lets you hide presets, which can reduce the 

number of visible presets to a manageable level without actually deleting the 

preset. 
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1. In the User Preset menu, use INC or DEC to select the slot where you want the new 
preset. Selecting an EMPTY PRESET is usually better unless you are intentionally 
overwriting an existing preset. Press and hold INC or DEC to scroll rapidly. 

2. Press INC+DEC to access options. 

3. In the Choose TASK? screen, press INC until you see Manage Presets, then press 

ENTER. 

4. In the Clear Current Preset? > N screen, press ENTER. 

5. In the Copy Preset from Library? screen, press INC to display Y, then press 

ENTER. 

6. In the Library Preset list, press INC or DEC to select the Library Preset you 
want to copy, then press ENTER. 

7. In the Confirm COPY from Library? screen, press INC to display Y, then press 

ENTER. 

8. In the Library Preset has been Copied screen, press and hold BACK to 
return to the User Preset menu. Youôll see the new preset. 

9. As needed, modify the new presetôs properties.  
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Using the Charge Control Software 
 
 
 

About the CCS 
 
The free PowerLab 8 Charge Control Software (CCS) gives you unparalleled ability to customize the PowerLab 8.  
In order to connect the PowerLab 8 to the computer and use the CCS, you are required to use one of the FMA PC 
USB Interfaces; either the FUIM2 or the FUIM3. 
 
This table lists common CCS tasks. What do you want to do? 
 

To do this... Go here...  

Download and install the Charge Control Software  Details 
Monitor pack voltage, cell voltage and other data during Cells tab Details 
charging   

Initiate and control charging from CCS Cells tab Details 

View charge data in real-time graphs View > Graphs command Details 
Change graph update interval View > Preferences > Graphing Update Details 

 Rate command  

View cell internal resistance during charging Int. Res. tab Details 

Monitor supply voltage and current during charging Supply tab Details 
Specify default power source type, and set power source Supply tab Details 
operating parameters   

Update PowerLab 8 firmware Firmware tab Details 

Update Library Presets Firmware tab Details 

Restore factory User Presets Firmware tab Details 

Configure, save and load PowerLab 8 options Options tab Details 

Modify User Preset parameters Presets tab Details 

Show, hide, reorder, save and load presets Presets tab Details 

Correct preset errors Errors tab Details 

Generate a custom fuel table (Fuel Wizard) Tools > Generate Fuel command Details 

Run multiple CCS instances  Details 
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Installing the CCS 
 

Install the Charge Control Software (CCS) from the PowerLab 8 Software Install page (in 
the REVOLECTRIX Web site) using one of the methods detailed there. 

Once the software is installed, it will automatically check the Web site for updates in the 
background each time it is started. The next time you launch the CCS, it will ask you if 
you want to upgrade to the latest version.  Firmware and Library Preset updates are 
included in the PC software updates. 

Version upgrade 
 

As of October 2010, PowerLab 8 V2 firmware and CCS software is available at the 
PowerLab 8 V2 Software Install page. This version includes the following major 
features/capabilities: 

Á Expansion Channel Mode is available.  

Á Supports 40A maximum charge rate.  

Á Supports 40A maximum discharge rate (when using regenerative discharge mode).  

Á Supports 1344 Watts.  

Installing V2 will render any V1 presets obsolete. The process of upgrading your V1 PL8 
to V2 will automatically update to the latest V2 firmware version and initiate a Factory 
Restore. The V2 upgrade is NOT mandatory. Additionally, any V2 equipped PL8 can be 
downgraded to V1 by reinstalling the V1 firmware.

http://www.revolectrix.com/new_applications/software/pl8_software_v2.html
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Cells tab 
 

Monitor charge and discharge data in the Cells tab. You can also select a preset and 
start/stop PowerLab 8 operations in this tab. 

Operating from the Cells tab 
 

1. Connect the pack to the PowerLab 8. 

2. In the Cells tab, open the User Preset menu (near the bottom of the tab), then select 
the preset you want to use for charging. Selecting a preset here also selects it on the 
PowerLab 8. 

3. To change the selected presetôs settings:  

a. Click the Edit button. This opens the Presets tab and selects the preset. 

b. Change preset properties as needed. 

c. Click the Update button. 

d. Return to the Cells tab. 
 

4. Click the Start button. This opens the Start dialog. 

5. Review the settings and change them as needed. 

6. Click the button for what you want to do:  

Á CHARGE ONLY (i.e., no discharge). 

Á DISCHARGE ONLY (i.e., no charge). 

Á MONITOR (no charge or discharge, just monitor cell voltages).  

Á n CYCLE (perform n charge/discharge cycles, as specified in preset).  

7. In the next dialog, verify that the presetôs chemistry matches the packôs chemistry.  
This safety check is your chance to prevent charging if the preset and pack donôt 
match. 

Á If the displayed chemistry matches the packôs chemistry, click OK to start 

charging. Go to step 5. 

 

Or 

Á If the displayed chemistry does not match the packôs chemistry, do nothingðthe 

operation will time out. Close the dialog. In the Cells tab, click the RESET button. 

Start over at step 2. 

 

8. In the next dialog: 

Á Enter a name for the graph to be displayed during the operation, then click OK.  

All graphing functions may be disabled from the main menu by selecting View > 

Preferences > Disable All Graphing 

 

Or 

Á If you donôt want to graph the operation, click Cancel. (You can display a graph 

later if you change your mind.) 

 

9. During charging: 

Á Monitor charge/discharge data in the left panel of the Cells tab. Elapsed time 

is displayed in the lower left corner. (If you are operating using Expansion 

Channel Mode with multiple PowerLabs, use the list in the right panel to display 

data from a selected unit.) 



 41 

 

Á Monitor progress in graphs. 

Á To stop operations: Click the STOP button.  

 

10. When the operation is complete, PowerLab 8 will ñbeep beep beepò several times. 

 
11. Disconnect the pack from PowerLab 8. 

 

Helpful hints 
 

Á Fuel percentage will not be displayed during discharge.  

Á Fuel percentage is only accurate if you are using a preset having a fuel table 

thatôs appropriate for your pack. If you canôt find a preset with a fuel table that 

matches your pack, you can generate one using the Fuel Table Wizard.  

Á Cell 1 is the cell connected to the packôs negative lead.  

Á Cell Bypass indicates the percentage of bypass applied for cell balancing: 0% = 

charging normally, 100% = full bypass to allow other cells to catch up.  

Á The mAh IN/OUT field shows the mAh value of the previous operation, if available. 

This is especially useful when cycling a pack, as you can see what the previous 

discharge mAh value was even when the charge mAh is increasing. Keep in mind that 

batteries take more energy to charge than they deliver, so the mAh IN will usually be 

larger than the mAh OUT.  

Á Once you start an operation, you cannot modify the preset. If you made an error when 

editing the preset, stop the operation, edit the preset, update the PowerLab 8, then 

restart the operation. You can queue up preset edits, but you canôt update the 

PowerLab 8 until it is stopped.  

Á You can override charge or discharge currents during an operation by pressing the 

ENTER button on the PowerLab 8. This temporarily changes the current setting (the 

change is not saved to the preset). 

 
 
See also 
Charge/discharge/cycle/monitor a pack 
 
 

Tip: Hover the cursor over each data line for a brief description. 

Note: NiMH, NiCd and Lead Acid User Presets may switch to trickle charge 

(depending on how the preset is configured) when charging is complete. 
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Internal Resistance tab 
 

The Int. Res. tab displays cell internal resistance when charging LiPo and A123 
balanced packs. Internal resistance is not calculated or displayed during discharge 
cycles. 

 
If you are charging using multiple PowerLabs set for Expansion Channel mode, use the 
list in the right panel to display data from a selected unit. 

Viewing individual internal cell resistance enables you to more accurately evaluate pack 
quality and condition. If all cells show a low internal resistance, thatôs a good indicator 
that the pack can be charged and discharged at a higher C rate. Here are two examples: 

Á A pack rated at 5C and 40ï50C discharge may have an internal cell resistance of 2 

milliohms. This low resistance allows larger currents into and out of the pack with-out 

generating excessive heat.  

Á A pack rated at 2C charge and 20ï30C discharge may have 17 to 20 milliohms 

internal cell resistance. The higher resistance prevents the pack from charging or 

discharging as quickly, and the larger resistance will generate more heat during those 

operations.  

A cell poorly matched to the other cells in a pack will show a substantially different 
internal resistance. Also, a cell with high internal resistance compared to other cells may 
indicate the cell is weakening, which can degrade overall pack performance. 

Be aware that individual cell resistance will vary during charge. This is normal and 
results from the different voltages and currents applied to the pack during charging. 

Use the PowerLab 8 as a tool, measuring and record the internal resistance of your 
packs over time.  Look for trends that would indicate the IR of a cell or a pack is 
increasing over time.  This is a good indication that the pack is aging or has internal 
damage and should be replaced eventually.

Note: Internal resistance can only be measured on packs charged from below 

75% of capacity. It takes less than 3 minutes to calculate internal resistance. 

Internal resistance can only be calculated during charging, and only when the 

pack is connected using both the balance wires and discharge wires. 
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Supply tab 
 

Use the Supply tab to: 

Á Set the default power source type. 

Á Specify power source voltage and current limits. 

Á Monitor power source voltage, current and wattage.  

 

DC Power Supply section 
 

Á Enabled:  If checked, a DC power supply is the selected power source. 

Á Supply Low Voltage Limit: Set to a value just below the power supplyôs normal 

output voltage. If the supply voltage falls below this level, PowerLab 8 operations will 

stop. If the voltage drops fast enough, the PowerLab 8 may reboot. 

Á Current Limit: Set to match (or lower than) power supplyôs maximum current. If the 

charge rate is set higher than the input current allows, the PowerLab 8 will draw no 

more than the level set here, which may limit output current to the pack. Typically set 

this current limit to an amp or two below the power supplyôs specified maximum output 

current.  

 

Supply Status section 
 

Á Supply Voltage:  Real-time power source voltage and current. 

Á Output:  Real-time power source power output. 

Á Power Status: displays ñNormal (No Limiting)ò if the power source is operating within 

limits set on this page. An appropriate message will be displayed if the power source 

limits are exceeded. 

If you are charging using multiple PowerLabs set for Expansion Channel mode, use the 
list in the lower right panel to display data from a selected unit. 

 

Battery Power Source section 
 

Á Enabled:  If checked, a battery is the selected power source. 

Á Battery Type list:  Select battery type being used to power PowerLab 8. Values in 

this listôs templates are a starting point. Change the following settings as needed. 

Á Show Warning at 50% DOD: If checked, PowerLab 8 measures battery voltage 

when first connected. If the battery is below 50% depth of discharge (below that point, 

most flooded Lead Acid batteries are damaged), PowerLab 8 beeps and issues a 

warning. Press the BACK button to cancel the operation on the PowerLab 8, then 

correct the situation. (You could press the ENTER button to proceed, but this is not 

recommended.) 

Á Battery Low Voltage Out: Set to low voltage cutoff value. If battery reaches this 

voltage, charging stops to prevent over-discharge. 11.00V is recommended for most 

12V batteries. For a 24V supply battery PowerLab 8 auto-detects two 12V batteries in 

series and doubles the Battery Low Voltage Out setting selected.  
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Á Battery Max Amps Out: Set for maximum supply battery current draw. If the charge 

rate is set higher than the input current allows, the PowerLab 8 will draw no more than 

the level set here, which may limit output current to the pack. If Battery Max Amps 

Out is set too high, the batteryôs output voltage may drop below the Battery Low 

Voltage Out setting and charging will stop and the input battery could be damaged 

from excessive current draw. 

Á Enable Regenerative Discharge: If checked, pack discharge energy (up to 

40A/1344W) is sent to supply battery during discharge cycles.  If not checked, 

discharge is dissipated internally (limited to 100W).  

Á Regen. Amps IN to Pb: Set to maximum regenerative current to supply battery. 

Consider battery chemistry and size when setting this value. For example, Lead Acid 

batteries should not be charged at a rate higher than C/8. 

 
Á Regen. Charge Voltage IN to Pb: Set to maximum regenerative voltage applied to 

supply battery. For a 24V supply battery, PowerLab 8 will automatically double the 

value set here. If the regenerative voltage reaches the value set here, PowerLab 8 

switches to internal discharge to prevent the supply battery from being overcharged.  

 

Expansion Channel section 
 

If multiple PowerLabs are operating in Expansion Channel Mode, select the channel 
from which supply data will be displayed. 

 
 
 
 
 
See also 
Smart Power Management 
Power supplies 

CAUTION: An excessively high and sustained regenerative current back into 

the supply battery can harm the battery and reduce its useful life.  Always 

follow the input battery manufacturerôs recommendations when setting up for 

regenerative discharge. 



 45 

Firmware tab 
 

The Firmware tab enables you to: 

Á Determine the firmware currently installed in the PowerLab 8: it is displayed in the 

center of the tab. (Firmware version is also displayed in the PowerLab 8 power-on 

ñwelcomeò screen.) 

Á Install the latest firmware version. 

Á Download and install the latest Library Presets. 

Á Restore the factory presets and options.  

 
 

To update PowerLab 8ôs firmware: 

 
1. Disconnect all battery packs. 

2. Disconnect expansion unit(s). 

3. Apply power to PowerLab 8 from a 12-24V source. 

4. Set the connected PowerLab 8 as the primary unit (see step 3 in Expansion Channel 
Mode for details). 

5. Connect the PowerLab 8 to your computer using an FUIM2 or FUIM3 interface. 

6. In the CCS Firmware tab, click the firmware version you want from the list, then click 
the Update Firmware button. 

 

 

 
7. In the ñFirmware Programming Completeò dialog, click the OK button. 

 

To update the Library Presets: 

 
1. Click the Update Library button. 

2. In the confirmation dialog, click the Yes button. 

3. You will be notified when the update is complete. In the dialog, click the OK button. 

  
To restore the factory presets, PL8 options, and Supply Tab settings: 

1. Click the Factory Restore button. 

2. In the confirmation dialog, click the Yes button. 

3. You will be notified when the restore is complete. In the dialog, click the OK button. 

 

Tip: You can display similar instructions in the Firmware tab by clicking Click 

to view instructions. 

Note: Do not interrupt the firmware update! 

Tip: Time remaining for the firmware update is displayed just below the 

Update Firmware button. 

Tip: Factory Restore will replace all of the Library and User presets in the PL8 

with the latest factory defaults.  If you have custom presets designed, back 

them up one at a time to your HD for recall later, or consider using the Update 

Library tool if you just want the latest Library Presets available in an update. 
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Full firmware and preset update process 
 

Over time, new CCS versions and new factory default presets will be released. These 
changes may correct safety violations or provide enhanced capabilities that would cause 
older presets to contain errors when running in newer firmware or CCS software. This 
procedure enables you to update your custom presets as well as the firmware: 

1. Back up your custom presets one at a time using the File > Save Preset X to File 
command. 

2. Update the firmware (see instructions above). 

3. Perform a factory restore (see instructions above). 

4. Restore custom presets one at a time using the File > Open File to Preset X 
command. 

5. Check the Errors tab to see whether any of the old presets cause an error in the new 
CCS/firmware. Double-click each error and correct the problem. 

6. Re-save your custom presets one at a time using the File > Save Preset X to File 
command.  
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Options tab 
 

In the Options tab you can: 

 
Á Specify how information appears in PowerLab 8ôs display. 

Á Control whether preset changes made at the PowerLab are uploaded to the CCS. 

Á Specify speaker volume and beep settings. 

Á Set startup options. 

Á Save and load option sets. 

 

Visual Settings section 
 

Á Cells Scroll Seconds:  Set time for cell data to display during charging. 

Á Cell Decimals:  Set cell voltage values in hundredths or thousandths of a volt. 

Á Name on Both Lines: Set time that a long preset name appears in both lines before 

second line is replaced with charge specs. 

Á Preset Name Scrolling: Set time that portions of a long preset name appear in the 

displayôs top line.  

Á European comma decimal:  When checked, comma is displayed as decimal point. 

Á Text boxes:  Substitute your own text in the power-on ñwelcomeò screen. 

 

Preset Settings section 
 

Á Save Preset Changes done at PowerLab: When checked, preset changes made at 

PowerLab 8 are stored in the current preset and uploaded to the CCS. Disabling this 

option is not recommended, but provides a method for temporarily overriding a 

presetôs parameters for the duration of one charge.  No matter what you choose for 

this option, you can always over-ride charge and discharge rate on-the-fly at the 

PowerLab 8 after a charge is started by pressing ENTER.  This method never 

saves the changes to the preset in use. 

 

Audio Settings section 
 

Á Speaker Volume:  Set PowerLab 8 speaker volume. 

Á Charge Done Beeps: Set the number of beeps announcing that charging is 

complete. 

Á Button Clicks ON: When checked, PowerLab 8 emits a beep each time a button on 

its front panel is pressed.  

Á Quiet Charging:  When checked, does not beep at key points during charging.  

 

Start Settings section 
 

Note: After changing anything in the Options tab, click the Update button to 

download the changes to PowerLab 8. 

Tip: Enter your name and/or phone number in the text boxes. 
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Á Node Wiring =:  When set to FMA Wiring, PowerLab looks for FMA/Cellpro wiring 

convention on the balance port.  When set to XH/EH Wiring, PowerLab looks for the 

JST XH/EH wiring convention on the balance port.  See FMA Wiring mode vs. XH/EH 

Wiring mode later in this user guide for more details. 

Á Enable Quick Start: When checked, you can skip over a presetôs questions 

regarding available modes of operationðjust press and hold ENTERðwhen 

preparing to charge a pack at the PowerLab 8. 

Á Suppress Use Bananas Question:  When checked, the charge sequence does not 

ask whether you are charging using the banana cable. 

 
Á Choose Power Source at Startup: When checked, you must always specify the 

power source immediately after applying power to PowerLab 8. 

 

Save and load options 
 

To save a set of options on your computer: Click the Save to File... button. Select a 
Folder, enter a name, then click the Save button. 

To load a set of options from your computer: 

1. Click the Load from File... button. 

2. Locate and select the options file, then click the Open button. 

3. Click the Update button to download the options to PowerLab 8.  

Note: If this option is checked, PowerLab 8 assumes you are charging using 

the banana cable.  Attempting to charge using only balance wires will result in 

a Safety Code. 

Tip: If you always use the same power source, specify the power source in 

the Supply tab, then uncheck the Choose Power Source at Startup option. 

This will save you a step each time you power up the PowerLab 8. 
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Presets tab 
 

The Charge Control Software gives you almost total control over User Presets, including 
which ones are available in PowerLab 8, the order in which they are displayed, charging 
characteristics and the content and order of data screens displayed during charging. 

 

Edit a User Preset 
 

1. If the Advanced Properties option is checked, uncheck it. (See ñAdvanced 
properties,ò below, for more information about this option.) 

2. In the left panel, click the User Preset you want to edit. Parameters and screens for 
the preset are displayed in the right panel. 

3. Then:  
 

Á To change preset order: In the left panel, drag the preset number up or down. 

Á To prevent the preset from being displayed in PowerLab 8: Open the list next to 

the preset and click Hide. 

Á To change charge characteristics: Click the Properties tab in the right panel, then 

set options as needed. 

Á To change charge data screens:  Click the Screens tab in the right panel, then... 

¶ To change what a screen displays: Click the arrow next to the screen 

preview, then select the desired information in the drop-down list. 

¶ To show or hide a data screen:  Select Show or Hide as appropriate. 

¶ To change screen order: Drag the screen number up or down. 

 

4. Click the Update button. 
 

Or 
 

If you donôt want to apply the changes, click the Cancel button. 

 

Information about properties 
 

To view a brief description of a property: Hover the cursor over the property label. 

To view a detailed description of a property: Click the property label. The description will 
appear in a pop-up window. 

Note: The Charge Control Software performs extensive checks to make 

certain you have specified permissible charge parameters. If it finds errors, it 

will not download presets to PowerLab 8 until the errors are corrected. Errors 

are displayed in the Errors tab. To correct an error, double-click the error in 

the Errors tab; you will be taken to the corresponding preset property, which 

you can change to an acceptable value. 
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Save, load, backup and restore User Presets 
 

To save a User Preset: 

1. In the Presets tab, click the User Preset you want to save. The selected preset will 
have a gray background. 

2. File > Save Preset X to File... . This opens the Save a Preset dialog. 

3. Navigate to the Folder where you want to save the file. 

4. (Optional) Overwrite the default preset file name (this doesnôt change the presetôs 
display name). 

5. Click the Save button. 

 

 
To load a saved preset: 

1. In the Presets tab, click the User Preset location where you want the loaded pre-set 
to reside. The selected location will have a gray background. 

 

 
2. File > Open File to Preset X... . This opens the Open a File to Preset X dialog. 

3. Navigate to the Folder where the preset file is stored. 

4. Click the preset file. 

5. Click the Open button. 

6. Modify the preset as needed. 

7. Click the Update button to download User Presets to PowerLab 8. 

 

To load a preset from a saved graph: 

1. In the Presets tab, click the User Preset location where you want the loaded pre-set 
to reside. The selected location will have a gray background. 

2. File > Open Graph to Preset X... . This opens the Open a File to Preset X dialog. 

3. Navigate to the Folder where the graph file is stored. 

4. Click the graph file. 

5. Click the Open button. 

 

To save all User Presets in a single archive file: 

1. In any tab, File > Backup All User Presets... This opens the Backup User Presets 
dialog.  

2. Navigate to the Folder where you want to save the archive file. 

3. Enter a name for the archive file. 

4. Click the Save button.  
 

Tip: Save your custom presets individually, as described above, to have more 

flexibility when loading them. Later, you may need to initiate a factory restore to 

obtain the latest presets from REVOLECTRIX. If that occurs, you will appreciate 

having backup of all your custom presets.  Another method is to use the Update 

Library button instead of the Factory Restore button after performing a firmware 

update. 

Note: You can load a Library preset file into any User Preset location. The 

loaded file will over-write the preset in the selected location.  You can not load 

a preset file into any Library Preset location. 
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To restore all User Presets from an archive: 

 
1. In any tab, File > Restore All User Presets... . This opens the Restore User 

Presets dialog. 

2. Navigate to the Folder where the archive file is stored. 

3. Click the archive file. 

4. Click the Open button. 

5. Click the Update button to download User Presets to PowerLab 8. 

 

 

Advanced properties 
Basic properties cover charge and discharge parameters needed by most users. 
Advanced properties encompass an extended set of parameters that may be useful to 
users having special requirements. 

To view and set advanced properties: Activate the Advanced Properties option. Access 
advanced properties in the tabs over the right panel. 

 
 
 
 
See also 
Modify a preset 

Note: This operation will overwrite all User Presets. 

Tip: Use the Backup and Restore commands when you want to completely 

change the PowerLab 8ôs operations. For example, you might have one 

PowerLab 8 set up as your Lithium-only charger and another PowerLab 8 set 

up as your NiCd/NiMH-only charger. Bulk backing up is not a substitute for 

backing up individual custom presets. In the future, if you need to do a factory 

restore to get the latest presets, restoring the entire archive wonôt be much 

help. Many presets in an archive may generate errors when running in a 

newer firmware and/or CCS version. Itôs better to factory-restore all user 

presets, then load in your custom presets individually and correct any errors 

that show up (instructions for dealing with errors are provided in the Errors tab 

topic). 
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Errors tab 
 

The Errors tab lists preset errors detected by the CCS. 

If there are no preset errors, the tab is labeled No Errors. If there are preset errors 
present in the current CCS preset list, the tab is labeled X Errors, where X is the total 
number of errors found in all loaded pre-sets. 

To correct a preset error: In the Errors tab, double-click the error description. CCS 
displays the corresponding location in the presetôs properties list. 

 

Errors in custom presets 
 

When you customize a preset, CCS generally provides only valid options for various 
parameters. Itôs still possible to set conflicting values, however, so CCS checks all 
changes to make certain no safety rules are violated. 

 
Over time, new CCS versions and new factory default presets will be released. These 
changes may correct safety violations or provide enhanced capabilities that would cause 
older presets to contain errors when running in newer firmware or CCS software. This 
procedure enables you to update your custom presets as well as the firmware: 

 
1. Back up your custom presets one at a time using the File > Save Preset X to File 

command. 

2. Update the firmware (see instructions for the Firmware tab). 

3. Perform a factory restore (see instructions for the Firmware tab). 

4. Restore custom presets one at a time using the File > Open File to Preset X 
command. 

5. Check the Errors tab to see whether any of the old presets cause an error in the new 
CCS/firmware. Double-click each error and correct the problem. 

6. Re-save your custom presets one at a time using the File > Save Preset X to File 
command.

Note: If the CCS detects any preset Errors, it will not allow those presets to be 

loaded into the PowerLab.  The Update button will remain ñgrayed-outò until 

the errors are corrected. 
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Graphs 
 

CCS graphics enable you to see how battery performance changes over time during 
charging and discharging operations. 

When you start a charge, CCS opens a dialog in which you can name the graph. Enter a 
descriptive name, then click OK. 

 
To set graph update interval: In the main CCS window, View > Preferences > Graphing 
Update Rate. 

 
To disable all graphing: In the main CCS window, View > Preferences > Disable All 
Graphing. 

To view graphs: In the main CCS window, View > Graphs. This opens the Graph 
window. 

Perform the following operations in the Graph window. 

To select the parameter displayed in the graph: 

Á View > Amps vs. Time 

Á View > Cell Volts vs. Time 

Á View > Fallback vs. Time 

Á View > Fuel vs. Time 

Á View > Internal Resistance vs. Time 

Á View > Pack Capacity vs. Time 

Á View > Pack Volts vs. Time 

Á View > Cell Volts vs. Capacity 

 
To measure values and time in a graph: Hover the cursor over the graph. Value and time 
are displayed in the command bar. 

To customize graphs: View > Options. 

To zoom in: Drag a rectangle around the area you want to enlarge. After that, use the 
commands in the Zoom menu. 

To resize the graph window: Drag any corner or side, or click the windowôs Maximize 
button. 

To annotate a graph: Enter notes in the lower left corner.  

To save a graph as an image: File > Save As. 

To print a graph: File > Print. 

Note: At this point, the graph is being recorded in your computerôs memory. It 

is not yet saved to the hard drive. 

Tip: If your computer has plenty of RAM, choosing a smaller update interval is 

okay. For older computers, leave the update interval at the default 10 

seconds. 

Note: Availability of some graphs depends on the chemistry of the pack being 

charged. 
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After you generate a graph, perform the following operations in the main CCS window. 

To save graph data: File > Save Graph. (This saves all data, not just the data currently 
displayed in the graph.) 

 
To save graph data in a location of your choice: File > Save Graph As... 

To display previously saved data as a graph: File > Open Graph... . (You can view any 
parameters that were originally recorded.) 

To clear data from the Graph window: File > Close Graph. 

 

Exporting graph data 
 

You can export graph data for detailed analysis in other tools, such as spreadsheets. 
You donôt have to export graph data immediatelyðas long as you save a graph, you can 
open it later to export its data. 

CCS exports data in either of two formats: 

Á Tab-delimited text. This format exports all data recorded by CCS, including data that 

was not displayed in the graph. Some of this data is purely technical and relates to 

PowerLab 8 operation. Other data, such as supply voltage, can provide useful 

insights. 

Á BT2 format used by the West Mountain Radio CBA graphing software. This format 

exports only voltage versus charge. A BT2 file can be modified with a text editor. One 

suggested change is to update the file name on line 6, which may not be suitable for 

displaying in the CBA graph. 

To export graph data as a text file: File > Export Graph > Text File... 

To export voltage data in CBA format: File > Export Graph > West Mountain CBA II 
File... , select the data you want to export, then click the Export button. 

Tip: Unless graphing has been disabled, the CCS will prompt you to name a 

Graphing session each time a charge/discharge/monitor/cycle operation is 

started.  Later, if you start another session without saving the previous session 

to your Hard Drive, CCS will ask you if you want to over-write or start a new 

graphing session.  Then it will ask you to save the previous session to your 

HD with a file name.  CCS will also prompt you to save the graph to your HD if 

you stop charging or attempt to exit the program. 
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Generate a custom fuel table 
 

PowerLab 8 calculates the fuel level in a battery based on a lookup table for a particular 
cell manufacturer or chemistry. Even two LiPo batteries from different eras or different 
brands from the same era can have vastly different voltage-versus-time characteristics 
during charging. When the fuel table doesnôt match the cellôs chemical composition, 
errors in the fuel reading occur.  To read more, see the section How Auto Current Mode 
works in this user guide. 

An accurate fuel table can be generated by cycling a cell (or pack) and recording the cell 
voltage. The Fuel Table Wizard automates the process. However, it will take a few hours 
to complete. 

1. Tools > Generate Fuel. This opens the Fuel Wizard. 

2. Follow setup instructions in the Fuel Wizard. 

3. Click the Generate Fuel button. 

4. The Template preset is the user preset the Fuel Wizard will use to run the multiple 
cycles required to gather the required data to generate a new custom fuel table. 

5. The preset you save the data to will be updated with the new fuel table.  You can 
over-write an existing preset or select an Empty preset.  No matter which you select, 
you still need to enter a name for the resulting preset in Step 8. 

About fuel tables 
 

How do you know whether you need a custom fuel table for a battery? If you use Auto 
mode (AUTO 1C, 2C or 3C) for simplified charging, and your battery is anything other 
than a generic 15C to 20C LiPo, you probably need a custom fuel table. The clue is that 
the PowerLab 8 over-or under-calculates the optimum charge rate when using one of the 
Accurate Charge presets. 

Suppose you are about to charge a 2200mAh pack, and you set the PowerLab 8 for 
AUTO 2C charge. If the pack is mostly discharge when you start the charge, then within 
10ï20 minutes the current should gradually increase to around 4A (a perfect 2C charge 
would be 4.4A, but the PowerLab 8 is intentionally conservative in AUTO mode, even if 
the fuel table precisely matches the chemistry). 

If you see that the charge rate only reaches 1A or 2A, or it overshoots to 6A or higher, 
then you need to generate a custom fuel table to have PowerLab 8 correctly calculate 
AUTO rates for the pack. The alternative is to manually set the charge current to 4.4A 
when charging this pack. Be aware that PowerLab 8 will use available fuel table data 
during both AUTO and manual charge modes to estimate how much capacity remains in 
the pack being charged. 

Another way to know when a pack needs a custom fuel table: If the pack is charged to 
100%, then you fly for a short time and note that only 20% fuel is remaining. 

Tip: The slower the charge and discharge rate, and the lower the end-charge 

voltage is set, the more accurate the new custom fuel table will be.  But faster 

options are provided to reduce the time it requires, and to prevent discharging 

below a level that some might feel is too low for a particular battery. 

Note: Sometimes, if AUTO charge is not reaching the optimum charge rate, it 

is because the parameter Max Auto Amps is set too low in the user preset.  

This parameter can be found on the Fuel Tab of the CCS.  For High Power 

presets, this value can be set to a max of 30A, for most other presets, the max 

setting is 10A.  This is a safety feature to prevent the PowerLab from sending 

too much current to the battery in the event the fuel table is not accurate for 

the pack.  Use caution when changing this setting. 
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Run multiple CCS instances 
 

You can run multiple instances of CCS on one computer to support multiple PowerLabs. 
Hereôs how: 

1. Connect the first PowerLab 8 to the computer using an FUIM3. 

2. Launch CCS. Waiting to Start should appear at the top of the CCS window. 

3. Connect the next PowerLab 8 to the computer using another FUIM3. 

4. Launch CCS again (this will be the second instance). Waiting to Start should appear 
at the top of the CCS window. 

 
Configuration D and Configuration G in the ñConnect packs: advancedò section show 
wiring that supports multiple CCS instances. 
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Other information 
 
 
 

Charging tips 
 
 

General information 
 

Á Because PowerLabôs cell balancing technology monitors individual cells, you donôt 

need to cool a pack before charging it. Go from flying to charging to flying again 

without waiting. 

Á Cells in a pack have different voltages when they are discharged. PowerLab 8 

balances (equalizes) cell voltages while it is charging the pack. REVOLECTRIX 

chargers provide the highest available balance current in the industry: up to 1A, and 

now customer-adjustable. 

Á During charging, cells that charge the fastest are the weakest cells in the pack. At the 

end of charging, cells with the highest voltage are weakest. This happens because 

weaker cells have lower capacity, and they charge faster than stronger cells. 

Á If PowerLab 8 displays LOW VOLT RESTORE, the pack was over-discharged during 

its last use or there is an issue with the wiring of the pack(s) connected. The charger 

will attempt to repair LiPo cells measuring between 0.5V and 2.7V, or A123 cells 

measuring 0V to 2.0V. To avoid additional damage to restored cells, do not over-

discharge a repaired pack. 

 
Á By definition, end-of-life for a LiPo cell is when the cell can only be charged to 80% of 

its original capacity rating. The number of charge/discharge cycles a cell undergoes 

before reaching end of life depends on several factors, including cell quality, 

discharge rate, internal heat generated during use, and other parameters. Cells in an 

older pack may be more out of balance, but PowerLab 8 will still balance them to 

within 6mV by the end of charge. For this reason, it may take longer to balance older 

packs. The charger may show FUEL=99% for several hours while it is balancing a 

high capacity (3Ah and up) ñveteranò pack that is severely out of balance, but User 

Presets might be set to stop balancing after a preset time. Often, the last few millivolts 

of balancing take a very long time and do not significantly improve overall pack 

charge or performance.  

 

Charging packs 
 

Á You can top off packs, or remove them when they are partially charged. There is no 

way to damage a pack when using PowerLab 8. (The only exception to this is if you 

are using Safe Parallel Adapters and you accidentally connect two packs having 

CAUTION: LOW VOLTAGE RESTORE mode is designed to prevent fires 

when packs are damaged.  If you see the PowerLab go into this mode of 

operation, allow the pack to charge for a few minutes, then stop and re-start 

the charge.  But do not continue the process.  Locate the real cause of the 

problem.  Continuing to force over-ride LOW VOLTAGE RESTORE can result 

in fire. 
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different number of cells together in parallel. This is less a function of the PowerLab 8 

and more about assuring proper connection of packs to the PowerLab 8.) 

Á If a pack is at 80% or less of its capacity when connected to an auto-detect speed 

controller, the controller may lower its cut-off voltage. This could over-discharge the 

pack during the flight. Auto-detect speed controllers should properly set cut-off voltage 

if packs are charged to at least 90%. 

Á To save time, stop charging when the pack reaches about 95% of capacity. That last 

5% takes the longest. By default, User Presets notify you with two beeps when a pack 

reaches 90% of capacity (that threshold can be easily adjusted using the Charge 

Control Software). 

Á Some cells may sag 0.10V within an hour after charging. This is normal as packs age.  

Á In REVOLECTRIXôs opinion, over-discharging an A123 pack below 2.0V/cell will 

damage the cells (contrary to some reports). PowerLab 8 requires a minimum pack 

voltage of 1.5V to activate charging. If an A123 pack is below this voltage, do not try 

to repair the pack by boosting voltage. Even if you manage to repair the pack, it will 

not have many cycles left and PowerLab 8 will reject it for multiple reasons (as 

indicated by displayed Safety Codes). 

 

Storing packs 
 

Á For best results, LiPo and A123 packs should be stored at 50% of capacity. Use 

PowerLab 8ôs LiPo All Brands Storage Charge preset to prepare LiPo packs for 

storage, and the A123 All Cpcty Storage Charge to prepare A123 packs for storage. 

 
Á LiPo packs charged to 100% should not be cooled below room temperature. Cells at 

90% or less capacity can be cooled below 32ºF (0ºC). 

 

CAUTION: Be sure the storage preset matches the battery chemistry.  Using 

the incorrect preset will damage cells. 
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How Auto Current Mode works 
 

PowerLab 8ôs Auto Current Mode (indicated by the charge rate Ax.0C) precisely 
monitors individual cell fuel levels (cell voltages) in a LiPo, Li-Ion or A123 pack. If 
PowerLab 8 determines it is charging too fast, it slows down. Likewise, if it is charging 
too slow, it speeds up. PowerLab 8 adjusts charge current at one minute intervals 
throughout the charge cycle. 

When charging starts, it takes a short time for PowerLab 8 to determine the correct 
parameters, so it may ñhuntò for up to 30 minutes before it settles on the optimum cur-
rent. This is normal, and doesnôt harm the pack. The longer the charge, the more 
accurate the calculation. 

The plot below shows how Auto Current Mode adjusts the chargerôs current when 
charging a 2.1AH pack at 1.0C Auto. Initially, charge current is 500mA (this starting 
current is defined in the User Preset and is adjustable). Within a few minutes, PowerLab 
8 increases the current, and it eventually reaches 1.0C (1.9A in this example). This is 
slightly under the ideal 1.0C charge rate of 2.1A for this pack. Fuel rate Auto charging is 
intentionally calculated to be slightly conservative. Current drops as the pack reaches full 
charge (the charger changes to constant voltage mode). When charge current drops to 
about 0.05C, the pack is fully charged. If the cells are balanced, charging terminates. 
Termination settings are also controlled by the User Preset parameters. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

With the 1.0C Auto Current Mode, a fully discharged pack is charged to its nominal 
capacity in about 60 to 80 minutes, depending on the state of imbalance. Auto Current 
Mode takes into account a packôs starting charge level, so topping off a 50% discharged 
pack takes only about 30 minutes. 

 
If you find that Auto Current Mode is not properly calculating the ideal charge rate for a 
pack, that pack probably require a custom fuel table. See Generate a custom fuel table 
for details. 

 

IMPORTANT: Auto mode bases its calculations on the ñactualò capacity of the 

battery pack which may not be the same thing as packôs ñlabeledò capacity.  

Over time, the same preset may charge the same battery pack at lower and 

lower charge currents.  This is because the actual capacity of the pack will 

decrease over time.  This is normal.  
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Estimating performance factors 
 

If you donôt have a way to directly measure your propulsion systemôs electrical 
parameters, PowerLab 8 enables you to estimate them using before-and-after flight 
measurements. 

1. Collect data. 

a. Charge pack. 

b. When charging is finished, record Fuel % and total pack voltage (i.e. sum of cell 
voltages). 

c. Fly plane (or test on the ground). Record flight time in minutes. 

d. Connect pack to charger. Record Fuel % and total pack voltage.  
 

2. Calculate performance factors.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The ñLiPo Performance Estimatorò spreadsheet can also be downloaded from the 
Tech Docs section of the software downloads page of the REVOLECTRIX website. 

3. Evaluate results.  

Á Average current during flight gives you a rough idea whether system com-

ponentsðESC, motor, connectors and wiringðare operating within their current 

ratings. Keep in mind that peak current during flight may greatly exceed the aver-

age current you calculated. 

Á Watts per pound is an approximate indicator of aircraft performance (other factors 

influencing performance include lift, drag and motor type). Here are some guide-

lines:  

Á 25 to 30 watts per pound: level flight. 

Á 40 to 50 watts per pound: take off from smooth surface, climb. 

Á 50 to 75 watts per pound: take off from grass, sport aerobatics. 

Á 75 to 125 watts per pound: pattern aerobatics. 

Á Over 125 watts per pound: 3D.  

Note: The calculations outlined below work best when the pack is charged 

using a custom fuel table. They may be invalid if the fuel table does not match 

the pack under test. 

http://revolectrix.fmadirect.com/downloads.htm
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FMA Wiring mode vs. XH/EH Wiring mode 
 

By default, the PowerLab 8 ships with the balance connector (output) set for FMAôs 
Cellpro wiring.  This wiring mode supports all Cellpro REVOLECTRIX brand batteries 
and adapters directly.  However, due to the proliferation of the JST XH/EH balance 
connectors available on many LiPo battery packs in the R/C industry, the PowerLab also 
supports the popular XH/EH Wiring mode for the balance connector.  In the FMA Wiring 
mode, the PowerLab 8 always expects pack + on pin 9 of the PowerLabôs balance port 
on the front of the unit.  When switched to XH/EH mode, the PowerLab will look for pack 
+ on the last wire connected to the battery pack without any empty pins in between. 

If you already own XH/EH adapters that came with another brand of charger, for 
example, itôs easy to modify these to plug into the PowerLabôs balance port by cutting 
the adapterôs existing balance plug off and replacing it with the Cellpro 9 position battery 
pigtail (REVO PN: CPBP9P-10-US).  See illustrations on the following pages. 

Then, set the PowerLab 8 to XH/EH mode using one of the following methods: 

Switching to XH/EH mode at the PL8: 
 

1. Press INC+DEC (i.e., press both INC and DEC at the same time) to display the 
Options menu (Choose TASK?). 

2. Press INC or DEC until you see Charger Options, then press ENTER. 

3. Press ENTER until you see Node Connector? 

4. Press INC or DEC until you see XH/EH Wiring on line 2 of the LCD. 

5. Press and Hold BACK to return to the Preset Menu.  Your changes are saved the 
moment you make them. 

 

Switching to XH/EH mode using the CCS: 
 

1. Connect the PowerLab 8 to the PC via the FUIM2/FUIM3 PC USB interface, and 
apply power to the PowerLab 8. 

2. Once the PowerLab 8 is communicating with the CCS, access the Options tab. 

3. Under Start Settings, pull-down on the Node Wiring= field, and select XH/EH 
Wiring. 

4. Click the Update button at the bottom of the CCS to save your changes to the 
PowerLab 8. 
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Balance connector wiring 
 

When using FMA Wiring mode (Factory Default Setting) 
 

The following diagrams shows how a 9 pin Cellpro (JST PA series) balance connector 
(REVO PN CPBP9P-10-US) must be wired to an 8s, 7s, 6s, 5s, 4s, 3s, 2s, and 1s 
battery pack when the PowerLab 8 is set to FMA Wiring mode (Factory default).  
Whether the following is accomplished via the available adapters, or by physically 
connecting (soldering) the 9 pin Cellpro pigtail to a battery pack directly, this is what the 
PowerLab must see at its balance connector (output): 

Pin 1

Red

Black

Node 5

Node 6

Node 7

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

8s Pack
Pack positive

(red), 29.6V*

Node 4, 14.8V*

Node 5, 18.5V*

Node 6, 22.2V*

Node 7, 25.9V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 6

Cell 7

Cell 8

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/FMA Wiring Mode 
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Pin 1

Red

Black

Node 5

Node 6

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

7s Pack
Pack positive

(red), 25.9V*

Node 4, 14.8V*

Node 5, 18.5V*

Node 6, 22.2V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 6

Cell 7

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/FMA Wiring Mode 
 
 

Pin 1

Red

Black

Node 5

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

6s Pack
Pack positive

(red), 22.2V*

Node 4, 14.8V*

Node 5, 18.5V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 6

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/FMA Wiring Mode 
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Pin 1

Red

Black

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

5s Pack
Pack positive

(red), 18.5V*

Node 4, 14.8V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/FMA Wiring Mode 
 

Pin 1

Red

Black

Pack positive

Node 3

Node 2

Node 1

Pack negative

4s Pack
Pack positive

(red), 14.8V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/FMA Wiring Mode 
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Pin 1

Red

Black

Pack positive

Node 2

Node 1

Pack negative

3s Pack
Pack positive

(red), 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/FMA Wiring Mode 
 

Pin 1

Red

Black

Pack positive

Node 1

Pack negative

2s Pack
Pack positive

(red), 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  
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FMA Cellpro Connector/FMA Wiring Mode 
 
 

Pin 1

Red

Black

Pack positive

Pack negative

1s Pack
Pack positive

(red), 3.7V*

Pack negative
(blk), 0V

Cell 1

* Nominal voltage with
  respect to pack negative  

 
FMA Cellpro Connector/FMA Wiring Mode 
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When using XH/EH Wiring mode 
 

These diagrams show how a 9 pin Cellpro (JST PA series) balance connector (REVO 
PN CPBP9P-10-US) must be wired to an 8s, 7s, 6s, 5s, 4s, 3s, 2s, and 1s battery pack 
when the PowerLab 8 is set to XH/EH Wiring mode.  You may choose to set the 
PowerLab 8 to XH/EH MODE and splice the 9 pin Cellpro pigtail to an XH/EH adapter 
you already own.  Use these illustrations to guide you.  Whether the following is 
accomplished via the available adapters, or by physically connecting (soldering) the 9 
pin Cellpro pigtail to a battery pack directly, this is what the PowerLab must see at its 
balance connector (output): 

Pin 1

Red

Black

Node 5

Node 6

Node 7

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

8s Pack
Pack positive

(red), 29.6V*

Node 4, 14.8V*

Node 5, 18.5V*

Node 6, 22.2V*

Node 7, 25.9V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 6

Cell 7

Cell 8

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/XH and EH Wiring Mode 
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Pin 1

Black

Node 5

Node 6

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

7s Pack

Node 4, 14.8V*

Node 5, 18.5V*

Node 6, 22.2V*

Pack positive, 25.9V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 6

Cell 7

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/XH and EH Wiring Mode 
 

Pin 1

Black

Node 5

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

6s Pack

Node 4, 14.8V*

Node 5, 18.5V*

Pack positive, 22.2V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 6

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/XH and EH Wiring Mode 
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Pin 1

Black

Pack positive

Node 4

Node 3

Node 2

Node 1

Pack negative

5s Pack

Node 4, 14.8V*

Pack positive, 18.5V*

Node 3, 11.1V*

Node 2, 7.4V*

Node 1, 3.7V*

Pack negative
(blk), 0V

Cell 5

Cell 4

Cell 3

Cell 2

Cell 1

* Nominal voltage with
  respect to pack negative  

FMA Cellpro Connector/XH and EH Wiring Mode 
 

 
FMA Cellpro Connector/XH and EH Wiring Mode 




































